Problem after oil change - Porsche Cayenne Forums : Porsche Cayenne Forum
 
LinkBack Thread Tools
post #1 of 1 Old 11-25-2018, 10:33 AM Thread Starter
Junior Member
 
Join Date: May 2018
Posts: 3
Problem after oil change

I took my 2014 Cayenne Diesel to a local German shop. Used them before, never had a problem, great work and half the price of the dealer. This time not so.
It turns out one of the techs purchased it from the original owner. They told me they could work on the diesel, no problem. Had oil changed. Now the engine sounds different, and has a slight vibration. I also noticed the shifts are at a higher rpm, specifically 3rd to 4th. I also have a small oil leak.

The engine was smooth as silk before. Could they have used wrong oil?
Leak should not be a problem. Might be lose filter.
Shifting is very concerning. Any ideas why this would happen in a oil change??
tmlima is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Porsche Cayenne Forums : Porsche Cayenne Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome