Porsche Cayenne Forums banner
1 - 3 of 3 Posts

· Registered
Joined
·
40 Posts
Discussion Starter · #1 ·
2012 Cayenne S Hybrid with 163k miles.

My MIL (Check Engine Light) has been blinking on and off for the past 10k miles or so with error codes P0420 and P0430 (Cat Bank 1 and Cat Bank 2 below threshold).

In the beginning, the light would come on and then go back off by itself a day or two. The dealer told me if the light went off by itself, then not to worry about it. The light would stay off for a few weeks before coming back on. I've since switched to an independent Porsche service specialist (a very serious Porsche servicer and Porsche rally/race car builder because they are a huge discount to the dealer price) who also indicated if the light didn't stay on no big deal.

The frequency of the light coming on has increased noticeably and we've reached a point that after consultation with the service shop, I am resetting the MIL manually after checking that there aren't other codes present to better understand how many times the fault would trigger if the light weren't already on from a previous error, since sometimes it might stay on for three or four days. Generally, what I'm getting is an error every 2nd to 3rd day. Of course, the service shop says, most likely I need my cats replaced, which obviously isn't cheap, but certainly cheaper than buying a new Porsche.

After doing a lot of reading, I've learned the following...

1) The MIL indicator could be triggered by bad o2 sensors, not necessarily bad CATs
2) The CATs issue could simply be they are "oiled/fouled"
3) "Oiled/fouled" cats can be cleaned

So the question is, does anyone have any experience having a) had CAT issues with their Cayenne, b) had any experience with attempting to clean their CATs as a first step before replacing them, or c) had o2 sensor issues

Appreciate any thoughts. Thanks.
 

· Registered
Joined
·
8 Posts
I’m wondering the same. I have a 2016 Touareg TDI with 176k and seems like power is slightly down. Could the cat be getting clogged? Not sure how long before most start having issues?


Sent from my iPhone using Tapatalk Pro
 
1 - 3 of 3 Posts
Top